I cant start a Forge server



  • I want to play Minecraft with my friends but with my own mods, but when i try to start a forge server with GGServers the tab where it says how much memory and how much the cpu is using, it just disapears, it shows 0% on both cpu and memory, but the tab keeps on disapearing, can someone help me? do u have to add the mods to the server or can u add the mods to ur minecraft and just join the server?



  • @3gg_Ro11 In order for a mod to work on your server it must be added to the client and the server. So you must install the mod onto the server, and download it to your Minecraft mod folder, you being the client.

    Anyone who wants to play on your server must also download the mods for themselves.



  • Thank you!



  • @3gg_Ro11 You’re most welcome, let me know if it worked.



  • How do i add the mods to my server? What tab do i click on to add the mod files to the server?



  • @Terminator41000 PLZ HELP ME



  • @3gg_Ro11 Please refer to this link for accessing your server files

    https://ggservers.com/billing/knowledgebase/13/FTP-File-Access.html

    To install a mod, simply put the mod file into your servers mod folder.



  • @Terminator41000 But the server wont even start, the tab where it shows the memory and cpu just keeps on disapearing and the server dont start. https://gyazo.com/8f2b069c8a9f16afc727e082015d8983 look at this GIF. I can start the server with any other modpack but with forge the tab just disapears and the server dont start.



  • @3gg_Ro11 When starting your server, do you get any errors in the console?



  • @Terminator41000 07.01 16:05:34 [Multicraft] Server stopped
    07.01 16:05:34 [Multicraft] Looks like a crash, check the server console. Return value: 1
    07.01 16:05:34 [Multicraft] Restarting crashed server in 5 seconds
    07.01 16:05:34 [Multicraft] Server shut down (starting)
    07.01 16:05:34 [Server] INFO at cpw.mods.fml.relauncher.ServerLaunchWrapper.main(ServerLaunchWrapper.java:12)
    07.01 16:05:34 [Server] INFO at cpw.mods.fml.relauncher.ServerLaunchWrapper.run(ServerLaunchWrapper.java:25)
    07.01 16:05:34 [Server] INFO at java.lang.Class.forName(Unknown Source)
    07.01 16:05:34 [Server] INFO at java.lang.Class.forName0(Native Method)
    07.01 16:05:34 [Server] INFO at java.lang.ClassLoader.loadClass(Unknown Source)
    07.01 16:05:34 [Server] INFO at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
    07.01 16:05:34 [Server] INFO at java.lang.ClassLoader.loadClass(Unknown Source)
    07.01 16:05:34 [Server] INFO at java.net.URLClassLoader.findClass(Unknown Source)
    07.01 16:05:34 [Server] INFO You will need to add them to your server before FML and Forge will run successfully.java.lang.ClassNotFoundException: net.minecraft.launchwrapper.Launch
    07.01 16:05:34 [Server] INFO We appear to be missing one or more essential library files.
    07.01 16:05:34 [Multicraft] Updating eula.txt file
    07.01 16:05:34 [Multicraft] Loaded config for "Forge(1.7.10)"
    07.01 16:05:34 [Multicraft] Starting server!
    07.01 16:05:34 [Multicraft] Loading server properties
    This is what it says



  • @3gg_Ro11 [Server] INFO We appear to be missing one or more essential library files.
    Maybe this thing is important?



  • @3gg_Ro11 Try downloading the missing files from this link

    https://extravm.com/billing/kb_downloads/fml_libs15.zip

    Using the FTP, first make sure that these files are in the correct place, they should be in your servers /libraries folder, if not, extract the contents of that folder to the /libraries folder in your server, let me know if this helps.



  • @Terminator41000 I already have these 3 files in the library folder https://gyazo.com/1d50492cc4b571173b2c36171e64c45e should i add these 5 files https://gyazo.com/16433e68d9364c5a4a0ad9c3c074b845 also or remove those 3 files and add those 5 files??



  • @3gg_Ro11 I suggest extracting those jar files to the libraries folder, but keep the 3 folders that are already in there.



  • @Terminator41000 07.01 16:23:36 [Multicraft] Server stopped
    07.01 16:23:36 [Multicraft] Looks like a crash, check the server console. Return value: 1
    07.01 16:23:36 [Multicraft] Restarting crashed server in 5 seconds
    07.01 16:23:36 [Multicraft] Server shut down (starting)
    07.01 16:23:36 [Server] INFO at cpw.mods.fml.relauncher.ServerLaunchWrapper.main(ServerLaunchWrapper.java:12)
    07.01 16:23:36 [Server] INFO at cpw.mods.fml.relauncher.ServerLaunchWrapper.run(ServerLaunchWrapper.java:25)
    07.01 16:23:36 [Server] INFO at java.lang.Class.forName(Unknown Source)
    07.01 16:23:36 [Server] INFO at java.lang.Class.forName0(Native Method)
    07.01 16:23:36 [Server] INFO at java.lang.ClassLoader.loadClass(Unknown Source)
    07.01 16:23:36 [Server] INFO at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
    07.01 16:23:36 [Server] INFO at java.lang.ClassLoader.loadClass(Unknown Source)
    07.01 16:23:36 [Server] INFO at java.net.URLClassLoader.findClass(Unknown Source)
    07.01 16:23:36 [Server] INFO You will need to add them to your server before FML and Forge will run successfully.java.lang.ClassNotFoundException: net.minecraft.launchwrapper.Launch
    07.01 16:23:36 [Server] INFO We appear to be missing one or more essential library files.
    07.01 16:23:36 [Multicraft] Updating eula.txt file
    07.01 16:23:36 [Multicraft] Loaded config for "Forge(1.7.10)"
    07.01 16:23:36 [Multicraft] Starting server!
    07.01 16:23:36 [Multicraft] Loading server properties
    Its the same again!!! A file is missing! omg! i dont want to pay for a thing that i cant use, if u help me with this so it works, u r the best



  • @3gg_Ro11 The only other thing I could suggest is that you check that the minecraft jar file is in the correct place and is correctly named. In the jar folder there should be a vanilla minecraft jar file for whatever version you are running.

    Make sure it is in the /jar directory and is correctly named. For example, if you was running a 1.6.4 server, the jar name should be minecraft_server.1.6.4.jar as i believe that’s what forge would be looking for.



  • I dont know if i have a vanilla minecraft https://gyazo.com/a4a562e55915fd8b0de6405800e8b5db it looks like this for me in the jar file



  • @3gg_Ro11 Try downloading the vanilla minecraft server file for whatever version of forge you are using, place the file in your servers /jar directory.

    You can download the minecraft jar files from this website

    https://mcversions.net/

    Download the server jar and upload it to your server.



  • @Terminator41000 ofcourse it didnt work, [Server] INFO at cpw.mods.fml.relauncher.ServerLaunchWrapper.main(ServerLaunchWrapper.java:12)
    07.01 16:40:03 [Server] INFO at cpw.mods.fml.relauncher.ServerLaunchWrapper.run(ServerLaunchWrapper.java:25)
    07.01 16:40:03 [Server] INFO at java.lang.Class.forName(Unknown Source)
    07.01 16:40:03 [Server] INFO at java.lang.Class.forName0(Native Method)
    07.01 16:40:03 [Server] INFO at java.lang.ClassLoader.loadClass(Unknown Source)
    07.01 16:40:03 [Server] INFO at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
    07.01 16:40:03 [Server] INFO at java.lang.ClassLoader.loadClass(Unknown Source)
    07.01 16:40:03 [Server] INFO at java.net.URLClassLoader.findClass(Unknown Source)
    07.01 16:40:03 [Server] INFO You will need to add them to your server before FML and Forge will run successfully.java.lang.ClassNotFoundException: net.minecraft.launchwrapper.Launch
    07.01 16:40:03 [Server] INFO We appear to be missing one or more essential library files.
    what does this mean?? is it this thing who is causing all the trouble?



  • @3gg_Ro11 Yes it is the missing library files that seems to be the issue.

    Sorry I haven’t found a solution sooner. Try going to this website and downloading the installer.

    http://files.minecraftforge.net/maven/net/minecraftforge/forge

    When you download it, run the installer inside any folder you like, make sure you install the server option. Once you’ve gone through that process and installed it, it will generate a folder, inside that folder should be a libraries folder.

    Copy that libraries folder and put it in your servers folder, replacing the current libraries folder that is already in your server.


Log in to reply
 

Looks like your connection to GGServers Forums was lost, please wait while we try to reconnect.