Forge and modpack install issues



  • Ok, I did post a question in a similar post, but it is old and not sure it’ll be seen. Also, I wanted to add my console log to help troubleshoot. My issue is this. No matter what I’ve tried from the knowledgebase for forge, my server refuses to start. I’ve done the exact methid step by step to install forge in the knowledgebase andI keep getting the same error. Console log follows. I’ve also tried the custum .jar page in the knowledgebase, still same issue.

    Also, I know the server works. the setup I uploaded is one I’ve tested on my PC locally and it starts up as it should.

    Console log:
    30.03 05:18:08 [Multicraft] Server stopped
    30.03 05:18:08 [Multicraft] Received stop command
    30.03 05:18:05 [Multicraft] Server stopped
    30.03 05:18:05 [Multicraft] Looks like a crash, check the server console. Return value: 1
    30.03 05:18:05 [Multicraft] Restarting crashed server in 5 seconds
    30.03 05:18:05 [Multicraft] Server shut down (starting)
    30.03 05:18:05 [Server] INFO at net.minecraftforge.fml.relauncher.ServerLaunchWrapper.main(ServerLaunchWrapper.java:31)
    30.03 05:18:05 [Server] INFO at net.minecraftforge.fml.relauncher.ServerLaunchWrapper.run(ServerLaunchWrapper.java:44)
    30.03 05:18:05 [Server] INFO at java.lang.Class.forName(Unknown Source)
    30.03 05:18:05 [Server] INFO at java.lang.Class.forName0(Native Method)
    30.03 05:18:05 [Server] INFO at java.lang.ClassLoader.loadClass(Unknown Source)
    30.03 05:18:05 [Server] INFO at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
    30.03 05:18:05 [Server] INFO at java.lang.ClassLoader.loadClass(Unknown Source)
    30.03 05:18:05 [Server] INFO at java.net.URLClassLoader.findClass(Unknown Source)
    30.03 05:18:05 [Server] INFO You will need to add them to your server before FML and Forge will run successfully.java.lang.ClassNotFoundException: net.minecraft.launchwrapper.Launch
    30.03 05:18:05 [Server] INFO We appear to be missing one or more essential library files.
    30.03 05:18:05 [Multicraft] Updating eula.txt file
    30.03 05:18:05 [Multicraft] Loaded config for "Default Minecraft Server"
    30.03 05:18:05 [Multicraft] Starting server!
    30.03 05:18:05 [Multicraft] Loading server properties
    30.03 05:18:05 [Multicraft] Received start command

    Thank you for your time.



  • I managed to figure it out with the custum .jar entry. although you need to ammend it. I got it working by adding in the forge 1.10.2 server libraries folder to the jar folder as well as the custum named .jar. Hope this helps anyone in the future.


  • Mod

    Thank you for posting your solution.


Log in to reply
 

Looks like your connection to GGServers Forums was lost, please wait while we try to reconnect.