this site refuses to log me in

  • I’m using a separate email to post this so don’t bother giving me the “How did you post if you can’t log in?” bs. No matter how many times I enter the correct information I can’t log in and do anything with the server I just purchased. If I can’t log in I might as well get a refund since there’s no use in having something I will never be able to use.

  • I’m getting a refund, this no help from “busy staff” that hasn’t had a post to review in 7 days is not flying. I have a job I have to be at in a couple of hours and I don’t have time to sit around waiting for nonexistent staff to respond.

  • @Tuxedo-Hampster I’m just trying to help.
    Your Multicraft Panel credentials and your Client area login credentials are different things.
    Wich you can’t login?

  • I can sort of log in to the client site but the multicraft site doesn’t accept any of the login info I have, I’ve even tried changing the password for it and it still says it’s wrong.

  • I just tried to log into the multicraft side and it logged me in, not sure what all the refusing to work c**p was about but it seems to be ~fixed~? If this service continues to be self destructive I can’t see myself staying long. If anything changes I will update this thread.

  • @Tuxedo-Hampster hey Tuxedo, your multicraft panel password is different than your client area password.
    Your Multicraft credentials was sent to your email address after the purchase.

Log in to reply

Looks like your connection to GGServers Forums was lost, please wait while we try to reconnect.